Zhorn Software
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Go down
avatar
radiocam
Posts : 16
Join date : 2018-11-06

"Backups to keep" not working... I think   (v10.0d) Empty "Backups to keep" not working... I think (v10.0d)

Thu Dec 02, 2021 2:44 pm
Fortunately not under extreme duress, I had need to restore a backup from a few days ago, and ideally, search through a few of my daily backups to find a sticky that  I appear to have deleted (permanently)
My configuration for backups is Backup period: 24 hours, Backups to keep: 14.
Which I believe to mean: Take daily backups, keep up to 14 before you overwrite the oldest.

So when I went to browse my 14 days of backups, to my horror there's just one in the folder.
Screenshot of my settings:
"Backups to keep" not working... I think   (v10.0d) 2021-110

(Sorry for the size, have not done this image thing before)

Only possibility  can see is that the folder is a pcloud folder, (it's like Dropbox), a synced folder on my PC. Not sure if Stickies is unhappy with that.

But ... there *was* one backup - and it was from a fortnight ago. Which makes it look like it started with great intentions and then lost interest in the backup-ing, so to speak.

Any thoughts?  Very troubling because I had this great planned backup strategy where another program (SyncbackPro) does a copy of the fortnight collection once a week (I'm a belt and braces kind of guy) so in theory I should have had a pile of backups to sift through.
My lone little db file looks pretty forlorn.

Cheers
Sooyke
Sooyke
Posts : 430
Join date : 2018-04-28

"Backups to keep" not working... I think   (v10.0d) Empty Re: "Backups to keep" not working... I think (v10.0d)

Thu Dec 02, 2021 4:22 pm
You could try the manual backup and see if it works or gives an error  ( win10 has several error logfiles ).
avatar
radiocam
Posts : 16
Join date : 2018-11-06

"Backups to keep" not working... I think   (v10.0d) Empty Re: "Backups to keep" not working... I think (v10.0d)

Thu Dec 02, 2021 4:31 pm
Hi sooyke,
Yes, manual works fine.
I've set it up on another PC now, just to see if it's PC-specific. Both running much the same build of Windows  - but Stickies 10.1a on the other PC.
I'll give it a day or two and compare.
👍
avatar
radiocam
Posts : 16
Join date : 2018-11-06

"Backups to keep" not working... I think   (v10.0d) Empty Re: "Backups to keep" not working... I think (v10.0d)

Thu Dec 02, 2021 5:42 pm
Back sooner than I thought.
Had a sudden thought as i was shutting down (it's 4:15am here ... 😴 )
Checked the standard/default backup directory - and sure enough, there are 14 backups in there. (I still have a puzzle to deal with, though...)

So maybe I had it wrong. Looks like:
- Manual backups go into the "custom folder" you can specify
- Automatic backups go into the default backup folder, ignore your custom folder.

But also .. it's Dec 2nd.
So I'd expect that the fourteen backup files would date 14 days from yesterday (or even Nov 30)
But they don't.
The dates run from the 6th to the 20th of November.
Not sure why there's a gap in there (which is sort of a fortnight)
And... as I usually suspect my butterfingers, I won't say anything more till I also check my backup backup setup.
Because my SyncbackPro is probably doing a copy of 14 days of backup files, and then messing up its retention delete, deleting the wrong set.
The most recent fortnight rather than the earlier fortnight.

The wisdom of age is not caring or being embarrassed that it's you who messed up something , and just being happy to resolve the problem....
Admin
Admin
Admin
Posts : 359
Join date : 2018-03-30
Location : London
http://www.zhornsoftware.co.uk

"Backups to keep" not working... I think   (v10.0d) Empty Re: "Backups to keep" not working... I think (v10.0d)

Sun Dec 05, 2021 7:10 pm
Well ... it's good that the schedule is being kept, but not that your custom directory is being ignored.

Can you set the logging level up a notch, then wait for the next backup to happen (which will be 24 hours after the most recently written file in the backups directory), and then look in the activity.log file which is being written.  You can press control-shift-g in a note to open it easily.

It should say:

Backing up to default...
or
Backing up to custom...

Thanks,

Tom
avatar
radiocam
Posts : 16
Join date : 2018-11-06

"Backups to keep" not working... I think   (v10.0d) Empty Re: "Backups to keep" not working... I think (v10.0d)

Tue Dec 07, 2021 10:09 am
Will do, Tom.
A bit perplexing, this.
Haven't done much to monitor here as I've been busy on other stuff.
Was triggered to get back onto it by your post notification.
And I think using the log is pretty much a requirement now, because it has not been writing backups to either directory.
When I last posted, I thought I'd messed up the backup with my external program that backs up the backup directory to a NAS - but that wasn't the case.
And.. the last scheduled backup file created is dated 20th November.
Will be interesting to see what the log shows. (I've bumped it to "Activity")
I run an online session tomorrow where I use Stickies a fair bit, so the log will get a bit of exercise - hopefully not too much to make troubleshooting it difficult.
Shall report back here.
Cheers - and thanks!
avatar
radiocam
Posts : 16
Join date : 2018-11-06

"Backups to keep" not working... I think   (v10.0d) Empty Re: "Backups to keep" not working... I think (v10.0d)

Thu Dec 09, 2021 2:18 pm
OK, here's what I found in the log.. and I'm only pasting the lone backup entry that I found, because it has a lot of other stuff (which I'm happy to post, but it would probably just be noise to the focus here):

- I set the "Activity" logging level just before my last post, so around 9pm on the 7th Dec.
- I checked just now, after midnight on Friday the 10th, so should have had two days of backup. I mean, two [BACKUP] entries
- Entry from the 8th morning, (and I'll bracket it with the before and after entries):

8/12/2021 7:27 AM.00 [CLOSED  ] Destroyed sticky 624 (closed)
8/12/2021 8:06 AM.10 [BACKUP  ] Backing up to custom: P:\StickiesBackup\202112080806.db
8/12/2021 9:27 AM.01 [SLEEP   ] Waking sticky 133.  Sticky next wake time: 1638916020 (8/12/2021 9:27 AM.00), time now: 1638916021 (8/12/2021 9:27 AM.01)

- So it certainly has started using the custom directory. I am happy to give this lower priority as maybe something I did wrong before)
- But... there is no [BACKUP] entry for the next day, the 9th... The difference being that I started the PC only around 2:24 pm.
- As a matter of interest, here are all the entries for the 9th (with only the activity type, I stripped out the content from each, not of interest)
8/12/2021 11:20 PM.03 [CLOSED  ] Destroyed sticky 733 (appExit)
9/12/2021 2:24 PM.57 [CREATED ]
9/12/2021 2:24 PM.57 [CREATED ]
9/12/2021 2:24 PM.57 [CREATED ]
9/12/2021 2:24 PM.57 [CREATED ]
9/12/2021 2:24 PM.57 [CREATED ]
9/12/2021 2:24 PM.57 [CREATED ]
9/12/2021 2:24 PM.57 [CREATED ]
9/12/2021 2:24 PM.57 [CREATED ]
9/12/2021 2:24 PM.58 [CREATED ]
9/12/2021 2:24 PM.59 [CREATED ]
9/12/2021 2:24 PM.59 [CREATED ]
9/12/2021 2:25 PM.00 [CREATED ]
9/12/2021 2:25 PM.00 [CREATED ]
9/12/2021 2:25 PM.00 [CREATED ]
9/12/2021 2:25 PM.00 [CREATED ]
9/12/2021 2:25 PM.04 [SLEEP   ]
9/12/2021 2:25 PM.05 [CREATED ]
9/12/2021 2:32 PM.05 [CLOSED  ]
9/12/2021 2:44 PM.47 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:44 PM.48 [CLOSED  ]
9/12/2021 2:49 PM.58 [CREATED ]
9/12/2021 2:49 PM.59 [CREATED ]
9/12/2021 2:49 PM.59 [CREATED ]
9/12/2021 2:49 PM.59 [CREATED ]
9/12/2021 2:50 PM.00 [CREATED ]
9/12/2021 2:50 PM.00 [CREATED ]
9/12/2021 2:50 PM.00 [CREATED ]
9/12/2021 2:50 PM.00 [CREATED ]
9/12/2021 2:50 PM.00 [CREATED ]
9/12/2021 2:50 PM.02 [CREATED ]  
9/12/2021 2:50 PM.02 [CREATED ]
9/12/2021 2:50 PM.02 [CREATED ]
9/12/2021 2:50 PM.02 [CREATED ]
9/12/2021 2:50 PM.02 [CREATED ]
9/12/2021 9:10 PM.43 [CREATED ]
9/12/2021 9:10 PM.48 [CLOSED  ]

- And as another curiosity: It's 1:03 am here, and I was working with a couple of sticky stacks quite intensely, till midnight. Not sure why there are no log entries past 9:10PM.  Does it cache-and-dump or something?  Anyway, that is also not important - what is mystifying is that there is no backup entry for the 9th. Does it not backup past a certain time? Or only after running for a certain duration?

As you can see, I'm all over the place with my shutdowns and startups.
Shall check again later in the day and see what it's done.

Incidentally, the directory bears out the above: There's only the one file been added in the custom directory, and nothing new in the default backups dir.
I'm curious whether it is having trouble with the cloud directory, so I will let it run as is for a day or two, then change the custom directory to a non-cloud dir  (if you think that's worth anything?)

Cheers
avatar
radiocam
Posts : 16
Join date : 2018-11-06

"Backups to keep" not working... I think   (v10.0d) Empty [You can skip the middle posts, but do read this one]

Sat Dec 11, 2021 9:35 am
I'm usually not so assiduous about updating my posts. I think it shows just how much this (not so) little app has become integral to my PC life.
And I think I've got a handle on where my problem lies.
So here's what I did, (not that these seem to be the issue, but just to establish the env):
- Updated to latest, V10.1a 
- Changed my custom directory to a non-cloud directory, C:\StickiesBackupTest
- Set Backup period = 6 hours   <--- Here's my issue, methinks
- Set Backups to Keep = 14
- Logging set to Activity

Did the above last night, before shutdown
Turned on PC at 10:53AM today.
I will not copy the log in here, kinda boring to viewers
It's now 8:15PM
And there has been one backup captured in my custom directory (as configured) - at 4:53PM
Which is good.
But... here's the thing:
- It did not capture a backup when I started the PC this morning
- It captured the first backup 6 hours after start
- I expect it will get the second at 10:53PM, and continue at 6 hour intervals *as long as I have the PC up*
- And tomorrow (I anticipate) , it will repeat what it did today.

So yes, I will have a backup for each day *if the PC stays up for at least 6 hours*
But what happens if I set it at Backup period = 24 hours
Because it does not do a backup first thing at startup, it will wait till a 24-hour-duration timer ticks over - which will not happen in a normal day, right?
And when I shut down the PC, it will reset all that. So when I start up again, it will start another 24 hour timer  - and never get there

That's why (I'm pretty sure) it never captured (or captures) a backup.
At least on my PC - I don't know if this is specific to my environment.
Also, if I turn off "Take regular backups" does it default to the old system? Or just stop backing up?
Must say, I loved the old system. The interleaved duration backups were a very good idea, which I have set up in some of my other backup systems.
Because it seemed to always get me out of those awful situations where you delete a sticky that contains valuable info, and then not notice it for days. By which time a standard backup system will have created many backups with the data missing.

The moral here, (if I'm right): Set your backup duration for the minimum time that you keep your PC turned on every day.
That way, it will capture at least one backup per day.

The fix is probably: Force a backup every time the PC starts up.
Sooyke
Sooyke
Posts : 430
Join date : 2018-04-28

"Backups to keep" not working... I think   (v10.0d) Empty Re: "Backups to keep" not working... I think (v10.0d)

Sat Dec 11, 2021 11:26 am
.

Here is a post  from Tom Revell that shows how the time for a backup is found by the code .

https://zhornsoftware.forumotion.com/t440-change-time-of-daily-backup

If your last backup filename is ( added spaces )  2021 12 10  1554 , the next backup will be on 2021 12 11 1554 .
If you switch of your pc before 1554 ofcourse no backup can be taken but the first time you start stickies next morning it will after a minute create one normally this would be the next morning so the backup taken is actually from 12 11 but the filename will be 12 12 but the content is from the day before .

If the pc has not been on for some days , there are no backups but also no change in content of stickies and after a stickies start a backup will be created .


I tried to fool it by deleting all backups but this morning it seems it used " option B " to create the filetime / backuptime .So from what i see there is no problem with timing using 24/ 7 backups the default setting .


Best regards
Admin
Admin
Admin
Posts : 359
Join date : 2018-03-30
Location : London
http://www.zhornsoftware.co.uk

"Backups to keep" not working... I think   (v10.0d) Empty Re: "Backups to keep" not working... I think (v10.0d)

Sun Jan 02, 2022 1:29 pm
It doesn't prove anything, but I have my settings to be "every 48 hours" and "keep 6".  That's what I'm seeing - I've got six backups, named like this:

202112192215.db
202112212216.db
202112232217.db
202112281351.db
202112301351.db
202201011352.db

Break those into their dates (just by adding spaces and colons):

2021 12 19 22:15
2021 12 21 22:16
2021 12 23 22:17
2021 12 28 13:51
2021 12 30 13:51
2022 01 01 13:52

That fits the narrative - my backup time was around a quarter past ten at night every two days, but then because I was away for Christmas, the backup which should have taken place on the 25th at about 22:18 didn't happen.

When I next switched on my computer, around ten to two on the 28th when I was back home, Stickies realised that it had now been more than 48 hours since the last backup, so took one, and so now my backup time has shifted to about ten to two.

Setting the logging level higher will mean a log entry is written on app start which looks like:

02/01/2022 13:27:29 [GENERAL ] Most recent backup is: c:\Users\tom.revell\Documents\MyProjects\stickies\stickies101\backups\202111032037.db

This is my dev copy of Stickies, which is why the backup is ancient.  I've told it not to backup at all - there's no need as it's just test data.  Try changing the logging level on your instance, and restart the app.  What gets written - what's the most recent backup which Stickies finds please?

Tom
Sponsored content

"Backups to keep" not working... I think   (v10.0d) Empty Re: "Backups to keep" not working... I think (v10.0d)

Back to top
Permissions in this forum:
You can reply to topics in this forum